Exported clip not synced


#1

I’ve just started using Shotcut to try to make a music video using a series of images and an audio track. The images include the lyrics so it is important that the images sync perfectly with the audio.

The problem I am having is that when I align everything, it goes out of sync (by 2 or 3 seconds) when I export it or if I save it and open it as an MLT XML clip.

On further inspection, I have noticed that when I preview before saving, the audio I hear is out of sync with audio waveform by about 2 or 3 second, which leads me to conclude that the problem is with the audio preview function.

I can get round it by aligning everything correctly and the shifting the audio track by 2 or 3 seconds to the right before saving but it is frustrating not to be able to get it to work properly.

Can anyone tell me if this is a known issue, or whether I might be doing something wrong which is causing this problem?

Thanks in advance.


#2

I use the waveform generated as a very rough guide to let me know where changes occur, relying more on my own eyes and ears to make sure everything syncs. You end up playing two second segments half a dozen times, but at least you know it’s right. No-one can see your Shotcut track layout in the finished article so I wouldn’t worry as long as you get the result you want in the end.


#3

I’m happy using my ears instead of the waveform. The problem is the difference between how it sounds/syncs when previewing and how it sounds after it has been saved.

Can anyone offer an further guidance?


#4

Ah, I see. I think I may have misinterpreted your post then, sorry. I’ve never had that issue.


#5

It’s not uncommon to have sync issues if your hardware is struggling to keep up with the real time playback, I’d probably try to use the waveform once it’s loaded as opposed to listening because of that. That or edit the audio before hand separately(I use audacity for this)


#6

Thanks for your reply. I don’t think it’s a hardware issue as I have a brand new computer with reasonably high spec and there of no signs of it struggling. The audio I am using is produced in Garageband. I’m just importing the audio file to Shotcut to make the video with still images.

The issues seems be with the preview. It just doesn’t seem to play in sync with the waveform. The bar approaches the start of the waveform and then the sound starts 2 or 3 seconds later (from the beginning). But when it’s saved the audio starts where the waveform starts.


#7

Shotcut does struggle with stills, especially PNG.


#8

Thanks. I am using PNG so I may try converting to jpeg to see if that helps.

However, I have tried using just an audio track (M4A) with no stills and the problem is the same. The audio doesn’t start in preview until 2 or 3 seconds after the bar has gone past the start of the music on the waveform.

I’m wondering if it may be an issue with M4A audio files. Maybe I should try .wav too…


#9

Yes, happens here with .m4a but not .mp3 - so yeh, converting your audio should fix it.


#10

Been experimenting - it only seems to be a problem when the M4A is saved with a cover image embedded in the file. When I remove this option before saving it seems to work OK.

Not had this issue with other video editing software. Should I report this as a bug?

I’ve also found that it seems to be necessary to leave at least a second blank at the start of the audio file in order to able to hear the first second. If the audio starts immediately the first second seem be cut. This seems to be an issue with all audio files as far as I can tell. And the problem seems to be both with the preview and the saved version. Again, should I report this as a bug?

Thanks for all the feedback.