Export differs a lot from the editor and is partly black-ish

Hi Shotcut Community! :slight_smile:
(please move me if it’s not a bug but a help thread, ty)

What is your operating system?
WIN 11 Home
3800X - 16GB - RTX2060 - SSDs

What is your Shotcut version (see Help > About Shotcut)?
23.05.14 DE

Can you repeat the problem? If so, what are the steps?

As you can see in my linked video there is a jump in brightness when the text disappears which isn’t seen in the preview at all.

I don’t like to post all of my fully rendered videos for now but i reproduced this problem in a lot of other clips as well. Same settings.

I’d also like to add the filters which are applied to the main video and not just the text layer:
(translated from GER to ENG, so some filter names could be off a bit)
(order from top to bottom)

GPU: Video fade out: 2sec, not selected checkbox
GPU: Brightness: 150%
GPU: Video fade in: 4sec, not selected checkbox
Audio: Audio fade in: 2sec
Audio: Audio fade out: 2sec
Video: Grain, quickly(?): 7%
GPU: Contrast: 37%
GPU: Whitebalance: 6000
GPU: Vignette: 77%, 70%
Audio: Amplification / Volume: -15db

Now a combination of effects for adjusting the LUT effect’s intensity:

Video: Mask, simple form: overwrite, rectangle, frame is basically bigger than my project, 0° and 0%
GPU: Opacity: 69% (makes the LUT work at 69% intensity)
Video: LUT 3D: which .cube doesn’t matter with this problem so far, trilinear
Video: Mask, apply


All the filters do what I want, the export in general is way darker than my project, especially on YouTube but that’s what’s to be expected i guess so i counter that with my 150% brightness.

Have a nice day and take a break to breath, you deserve it!

There is already a bug report here about color when using LUT with GPU Effects. But also, I see you are mixing the order of Video (CPU) and GPU filters. You are not supposed to do that even though I see there are ways in the UI to make that happen. The reason is that it kills performance to copy video between CPU and GPU memory. Does the problem still occur if you turn off the Grain, Mask, Opacity, and LUT filters?

At first: Thanks for answering on my question!

I tried and rendered a lot during the last days with just the first seconds of my project.

Is there a general guide on the order of filters that you could recommend? I just clapped them in because i wanted them without caring about any order whatsoever how i would in Lumion and other software.

First I swapped every GPU effect out for the normal one. 1:1 which didn’t solve anything.
Rendering time was 1:1 about 45mins for 4k/60 from 120mbits to 70mbits with the settings i wrote above - on the hardware mentioned above.

Then i tried turing off all the filters you have mentioned which didn’t change the grey/black flicker after the text disappears.

What do you mean by

The quite significant difference in color and brightness after export vs editor? It felt like i get a brighter image after going from some gpu filters to pure normal/cpu tho.

(Hours later i found out that the text’s fade out stopped working at some point in time which is weird but let’s not make that into the topic for now.)

Only 2 things removed the grey-black flicker after the text:

  1. removing ALL video effects on the video clip
    (just fade in or out made it flicker too)
  2. completely removing the text-file from the timeline

Eventhough i removed all GPU filters i cannot turn off “GPU effects” under settings. The program says “The file you opened uses GPU effect, but GPU effects are not enabled”
They defo aren’t used in my timeline anymore.

Could that be a problem?

When i tried using a png with transparancy as text or a tree.png the same problem occured with no fade in/out of the png. It either didn’t fade (without check box) or it bug-faded around with a black background if the check box was on.

That’s my update for now and have a good day! :slight_smile: