Everything is coming up Invalid

You need to provide more information before I relist this.

" invalid" appearing in my exported projects.

I really don’t know what I’m doing wrong. It seems that intermittently when I export a video, the entire video just comes up as invalid.

Does the clip I have in the exported project, need to STAY in the playlist when I export the video? That’s the only thing I can think of that’ making my exported video have the word " invalid" popup. The single clips plays fine on the shotcut player however when I export & mix it in the project, it it’s just pitch black with the word " invalid" across it.

Sorry I don’t know if I’m providing the correct info. Please let me know if additional info is needed to solve this problem thx!

I don’t have missing files, nor is Shotcut telling me I’m missing files. Also, as I tried one time before if I dissolve 2 clip together, if I separate the transition with either of the clips, the word " invalid" also comes up, so however that is also NOT the cause.

P.S. I was using proxy, and I’ve stopped using proxy since and I seem to have less exported projects with “invalid” in it. I have no idea if these to issues are related, but I’m just trying everything to find out the cause. Thx

I do not know what version you are using (see Help > About Shotcut), but in case you upgraded to 21.05.01 and think that might be the problem, you can downgrade to 21.03.21 here:

1 Like

"Fixed and blank considered missing and blocking export (broke in v21.01)" sorry don’t quite understand what this means, can someone clarify? :thinking: :hugs:

ok let me try to understand this. :thinking:You are recommending for me to uninstall the latest version and install back the old one? I’m a bit worried since I’ve just upgraded, I’ve started new projects in the upgrade version. Will the new upgrade version projects not open/ play in the old version?

I opened another MLT project as a clip, and it was showing up as " invalid" on the editting players. This has happened repeated since yesterday I’ve upgraded Shotcut.

Any clue anyone?

This is like shooting fish in a barrel… :rofl: I have no idea what caused the “invalid” and now I’m anticipating problems If I down grade back lol haha :grimacing: thx!

Perhaps the same as this:

yup that’s exactly what happened with me it crashed about 20-30 just the past day.

What about clips that are just MP4 and not MLT, that plays fine in a regular player. Do you know what makes it " invalid"?

Thx alot… I was going crazy! :slightly_smiling_face: Still doesn’t solve my problem though and about the 20 hours I put in today because it kept showing " invalid" and kept crashing… feeling discouraged :frowning:

As to why, that’s for some one much smarter than me. I just figured out in the smallest amount of steps how to reproduce the issue.

If you need the use the MLT XML clip feature, probably will have to go back to the prior release (which is listed above by shotcut).

Thank you for that info.
:hugs: :slightly_smiling_face:
I just now I used a transparent color on the under the " open other" tab, and exported the file, reads invalid. I wonder if it’s their color box that is doing that. Can anyone export any clips at all with color with a windows 10? This is really like shooting fish in a barrel. :frowning:

That what I did back to 21.03.21

That was mistyped and should be “Fixed invalid and blank…”

Can anyone export any clips at all with color with a windows 10?

Yes, I can.

What about clips that are just MP4 and not MLT, that plays fine in a regular player. Do you know what makes it " invalid"?

That is a total mystery. Make this test, right-click the job, view the XML, save it, and upload it here please.

what did you do back in March?

tysm! I will do that, that’s all foreign to me. :slight_smile::slight_smile:

3 logs total of “invalid” and 1 “failed” export. :roll_eyes: First 2 exported “successful” and the entire clip is " invalid" :weary:3rd one just read " failed" :tired_face: in the job window. Help, anyone? :pleading_face: thx everyone! :slightly_smiling_face: :hugs:

Update: Just exported the same project with the same file, however this time instead of exporting only PART of timeline ( copy timeline to source) I just went straight to export. Suspecting could it be either of these things.

  1. the function " copy timeline to source not working properly?

  2. when only exporting PART of a timeline, there’s a glitch and it comes up as “invalid

fail1.txt (1.3 KB)
fail12.txt (1.3 KB)
faill13.txt (1.3 KB)

Yes, this is broken by the same bug that causes

It is fixed for the next version.

1 Like

ok… update! I am almost 90% certain it has to do with exporting partial timeline by " copy timeline to source" as I have not exported that way for the last few days and everything has been exporting fine. So it in conclusion one of these is malfunctioning

1. copy to timeline

1. partial timeline export

thx for the help​:slight_smile::slight_smile:

Interesting. Could you post some screenshots? I ask because I have never heard of that happening.

This is happening to me now.
Copy timeline to source.
Partial export.
To be clear, Shotcut goes through the export process as normal albeit a bit faster than I would expect. When you open the exported mp4 file it plays but consists of a black screen with white “INVALD” text and no audio.
This screenshot is the exported file being played back in the source viewer.

Also having issues using proxies - they are not being created although Shotcut says it is using them.

You need to upgrade to avoid these problems. There are two newer versions. But the project now might have some problems not correctable by the update.

Thanks for the swift reply.

Shotcut was still reporting itself as the latest version on startup so I hadn’t realised there were issues with 21.05.01.

Installed the latest version and am now able to perform the copy timeline to source and partial export.
Project seems undamaged- maybe because I usually save before any exporting is done and don’t save again until I make the next set of edits so project in theory unchanged since before the “INVALID” export.

Still not creating proxies so I’ll go to another thread for that.

Thanks again.