Display resolution issue with new v20.10.31

Hi Dan,

Thank you for your reply.
First of all, sorry for not having translated “PPP” which in french stands for “Points Par Pouce” (equivalent to Points Per Inch) : I should have written DPI.

You are right : my system display scale is set to 150% for a good readability.

As advised, I have added the option “–QT_SCALE_FACTOR 1” in the Target field.
The result is not as good as with the prior version since the width of the Menu is reduced by about 10% on the same monitor.
But it works and characters remain sharp.

For my understanding, I checked the journal for Shotcut v20.09.27 and for Shotcut v20.10.31 : both Application logs read the same “[Info ] MainWindow::MainWindow device pixel ratio = 2”.

So why the new version v20.10.31 has a different behaviour than the previous ones, not to mention the very recent v20.09.27 ?

Indeed, if you need to wear glasses for a better vision or simply if working on a display screen for a while is a little bit painful, a small display may become an issue.
I imagine not to be alone in this case.

The resolution of Shotcut layout (main screen and all windows) is not as usual with Shotcut version 20.10.31.
Up to Shotcut version 20.09.27 it has always been Ok.
But as of today after installing (or using the zip version) the display of characters is way too big.
When changing the PPP Parameters it becomes normal albeit the font is blurred.
Am I doing something wrong ?
Is it a bug ?
Is there anything that can be done ?
[Microsoft Windows 10 v1909 (Operating System v18363.1139)]

It follows your Windows display settings. The new version of the GUI library is better at handling display scale > 100% and possibly some text size settings, but it is not going to please everyone. I do not know what “PPP Parameters” is. In any case, we are unlikely to make any change here, and you can try running shotcut.exe with command line option --QT_SCALE_FACTOR 1. You can also try changing some things in the exe’s Properties > Compatibility > Change high DPI settings > High DPI scaling override.

If you reply to this please include more information about your windows display settings.

As I wrote before it depends on your system display scale, which neither of you reported.
Look I reproduced it for you by running at 150% on a 3840x2160 monitor.

When you look in View > Application log it reports:
[Info ] <MainWindow::MainWindow> device pixel ratio = 2

Because the GUI does not support fractional scaling and rounds 1.5 for 150% up to 2.

And here is what it looks like when you run it with the command line argument I provided:

You can put that into a shortcut’s Properties > Shortcut > Target.

Now, the log reports [Info ] <MainWindow::MainWindow> device pixel ratio = 1 .

I can also go into the exe’s Properties > Compatibility > Change high DPI settings > High DPI scaling override > System (Enhanced)

to achieve the same thing:

I am not going to downgrade our main GUI library. You can accept the new look and size, change your display scale, apply an override mentioned above, or run an older version. If choosing to accept the new text size, you might find it helpful to use View > Show Small Icons.

To answer the question “Why did it change?” Read the release notes. It is due to the Qt library upgrade. The version we were using was first released in May, 2017 and is no longer supported by its developer. If you want to understand even further, then you need to research the technical details on your own, and it is related to improving support for display scale > 100% aka high DPI.

I had to make a change to fix a different problem. This changes the default behavior of 150% display scale for the next version.



v20.11.07 (same as v20.10 with --QT_SCALE_FACTOR 1)

Where do I put the command line argument? I tried putting in the shortcut/target but it says it’s invalid.

Then you did it wrong. Look closely at the screenshot. Maybe you missed a space.

Ah, Yes you were right. But the result is worse. This is unusable in 1920/1080p.

I’m sticking for v20.09 for now unless there is a workaround for this. I understand that the scaling change was made for bigger displays but the impact on standard displays makes it too big to use.

The change was made by the main library we use and need to upgrade every couple of years.
Why do you say it is worse? Your screenshot looks OK to me except I suggest to adjust the panel dividers. There are also some options in the View menu like small icons and no text under icons.