Detached Audio of single clip cannot be deleted

What is your operating system?
|Description:|Ubuntu 23.10|
|Release:|23.10|

Running the Linux portable tar version.
Extracted into my ~/bin/Shotcut directory.

What is your Shotcut version (see Help > About Shotcut)?
Shotcut version 24.01.28

Can you repeat the problem? If so, what are the steps?
Yes, the problem is repeatable.
Select a video clip on the timeline
Right click on the clip and select Detach Audio
Select just the audio clip that was detached
Hit X to delete just the Audio clip.
The the audio AND the video clip are deleted.

The work around appears to be toggling Group/Ungroup.
If there is only one clip on the timeline, the Audio and Video cannot be Ungrouped.
You must have another clip on the timeline that you can select.
Then you can go back and select the audio clip you wish to delete.

This may be the same bug as reported in:
" [Detach Audio grouping: Audio clip not immediately linked with the video clip]"

It is not a bug. Making a group upon detach is by design. Related issues with respect to selection and appearing as a group immediately after detach are in other bug reports and already fixed for next version.
Read the release notes for how to select a member of a group. Finally, detaching audio is not the only or best way to remove audio. Use Properties > Audio > Track instead.

If there is only one clip on the timeline, the Audio and Video cannot be Ungrouped.

A workaround for now is to deselect and select.

1 Like

Thanks for the reply.
I see it listed in the release notes.
Changed Timeline > Detach Audio to automatically create a group.

Is there any way you could make this an option in Settings so we can turn on/off this feature?

Thanks.
Mitch

We’re going to turn it off completely for detach in the next version. The point in the release notes to understand is how to select a member of a group instead of the group.

This is done for the next release. Clips will no longer be grouped when doing “Detach Audio”.