Detach audio duplicates video filters on audio and leave audio filters on video

What is your operating system?
I7-10’ Geforce 2600

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.08.29 portable apps 64bit

Can you repeat the problem? If so, what are the steps?
I usually have 2 timeline tracks: video and audio. Normally I ignore the audio inside a video because I add my personal audio track and I synchronize them.
In my timeline I have video track MUTED. Below there is the audio track enabled.

Sometimes I want to use the audio internal to the video, so I have to “detach” it, and it finishes below, inside the audio track.

The bug is that all the filters inside the video are duplicated inside the audio track.
I consider it a bug, because audio track with “video” filters is unuseful, and of course, the video track without the audio part, keep the “audio” filters associated.

I ask then to correctly distribute filters based on their type, during “DETACH” process, leaving video filters on video track, and audio filters on detached audio track.

Should not this be more correct?