Dark theme not working as it should on Linux

Same problem as here:

But changing system theme to dark does NOT switch to dark theme in shotcut.
OS: LinuxMint 21.1

I really miss the dark theme and i wish that i can choose themes as before (white and dark). Because i don’t like to switch my whole system to dark only for some applications.
So i think the same as here:
https://forum.shotcut.org/t/shotcut-display-theme-is-gone/38742/3
Sorry, but It is a bug. :wink:
Edit:
It would be cool to choose between “light”, “dark”, “auto”.
Edit2:
Version is wrong. Should be 23.05.07

works fine, when using the flatpak version, I do not work in the AppImage version, It is not a bug in Shotcut, it is a QT6/AppImage issue IFAIK.


Thank you very much! You are right i am using the AppImage! I will try it with the flatpak then.

Qt 6 Quick Controls not using an app’s custom palette is probably a bug in Qt. Is Linux userspace fragmentation a bug? But removing a feature or menu item is not really a bug. You can use an older version that still has it. We moved to Qt 6 to fix some major bugs and compatibility issues. A big change often comes with sacrifices. After pouring immense amounts of energy into something and then realizing there are some minor drawbacks, what should one do? Quitting is one option. Moving forward and sacrifice is another.

The portable, AppImage, and Snap are all the same build. But the AppImage and Snap do not read desktop color theme while portable does (depending on your desktop environment software, its version, dependencies, and configuration). Go figure.

1 Like

Thank you very much for explaining that. I can absolutely feel with you, respectively understand what you mean (from my own experience).

Yes, I fill the same as in my mind its a bug.
Also advise to change display in OS doesnt apply to my Linux, as I have it done this way long before I installed Shotcut. Now only the Shotcut stands out with its bright white aperance.

I also mentioned that Polish language somehow changed to more English then Polish after last update.
So 3/4 menu in Shotcut is now in English, while Polish is sellected from Language Pane and restarted.
Anyway, looks like previous version suit my needs better then current. Only, I dont know how to move back the clock …

I’m using the flatpak on Linux Mint (up to date) both as well as the normal system package. The system package has dark mode. I’d love to try the tracking feature, but currently the flatpak is burning out both my occuli, so that’ll have to wait a bit. ^^

Thank you for the new update!

Look like Mint have issues with flatpaks and dark/mode

There is some instructions here to change the theme for qt/kde app here

I’m using the flatpak version of shotcut, on linux mint 21.1 xfce and I have a dark UI theme. I’ve only experienced a problem with the appimage version, but I don’t use it.

1 Like

Changing the desktop theme to Dark does not work for me in Linux Mint 21.1. @dimadjdocent any tips on making the Dark work? I’ve read the attached and installed a flatpack SC over the App ver, but I still have eyeball-searing white.

If anyone has success, PLEASE let us know.Thank you!


Unfortunately, I don’t know how to solve your problem. I have a shotcut responsive to the system theme. Perhaps it depends on the theme of the environment, I have XFCE “rat”.
I can’t say for certain, but maybe upgrading to xfce 4.18 helped (linux mint 21.1 comes with version 4.16 by default). I updated by additionally including the xubuntu repository.

This is fixed for the next version by restoring Settings > Theme

1 Like

@ dimadjdocent: thank you so much for the info, and the excellent video answer! I appreciate the trouble you went to, and the comment that it is working for you (info, info, info).

I’m also excited to see that the amazing Shotcut team is planning to change this in a new version!

1 Like

Thank you amazing Shotcut team. Back in business. YES! Love the software, love your work, and really appreciate (my seared eyeballs especially) the fix, really, really, really!

Thank you so much for fixing this! I am so relieved that it is now dark again! :smiling_face_with_three_hearts:

This update made me wonder :grin: If I choose the system theme, I see colored icons. Is this by design, or is it some kind of bug?
This will of course be purely my subjective opinion, but the discolored flat style of the icons looks much more modern than these colored ones.

Looks like this happens when you select “system”. Select “Fusion Dark” and you should see the black/white icons.

I know this, I checked it before posting here. I’m wondering if the colored icons are a bug or by design?

By design.