Crop Rectangle - Preset Values not updating dialog

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.09.13 64bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

I set a crop - rectangle filter to the values of 0,0 position and 0,0 size with transparency set.
I saved this as a preset.

The preset file contains this:

rect: 0 0 0 0 1
radius: 0
color: “#00000000

If I apply the preset then it actually works as expected, but the dialog bog is not updated with the values from the preset.

image

I created another preset with different values, and that updates as expected.

So the issue is probably due to me have zero values in my preset - not a major bug, so a low priority.

Why this preset? I am attempting Multi Cam editing.
If I have my 4 cameras stacked on 4 different tracks, then by using ][ (s split ) and up/down arrows - I can create a section in the tracks above the one I want displayed, which I can make invisible by adding a filter / preset.

In this screen shot, top two tracks are invisible, so third one is displayed.
image

Ideally, a simple “Invisible” filter would be a better option.

(This can be done with other filter types - which filter uses the least processing power?)

Or instead of a filter, a Hide Clip option for individual clips in the timeline. When right-clicking on a clip, the hide option would be there along with Cut, Copy, Remove, etc… And the hidden clips would be of a different color to differentiate them from the others. I can remember of a few times when that option would have been useful.

1 Like

@MusicalBox I agree a hide/unhide right click option makes better sense.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.