Crop and resize clip (without padding)

I have a video clip with irrelevant borders around the actual contents. I would like to crop it but without padding nor scaling - I just want to have smaller frames, frames with the size of the relevant contents. This would also result in a smaller file size without losing the quality (no stretching, scaling etc.).

How can I do this in Shotcut? I tried so far:

  • the crop source filter, but as a result the relevant contents was scaled up to the entire frame, with slight loss of quality (because of scaling) and which is far worse the size of the file was three times larger than the original,
  • the crop rectangle filter with padding set to transparent (I found such hint on this forum) but then the size of frames did not change (still causing problems when displaying the clip, as the displaying programs try to show both the border and the contents) neither did the file size get reduced (in fact it was slightly larger).

I just want to peel the clip from the black frame and get smaller file with smaller frames without losing quality :).

Any help would be appreciated!

1- Notez les dimensions de la vidéo du contenu actuel (sans les bordures). Pour ceci, utilisez le filtre Crop: Rectangle qui vous donnera cette information.
2- Créez un nouveau projet et définissez son mode vidéo avec les dimensions que vous avez noté en 1.
3- Appliquez un filtre SPR sur vos clip ou sur la piste en réglant mode sur “distort” et en ajustant les paramètres de dimensions.

1- Note the dimensions of the current content video (without the borders). For this, use the Crop: Rectangle filter which will give you this information.
2- Create a new project and define its video mode with the dimensions you noted in 1.
3- Apply an SPR filter to your clip or track by setting the mode to “distort” and adjusting the size parameters.


Thank you very much for your immediate help!

I tried your solution, but it worked only partially. The output file now has smaller frames (great!), but I still cannot get rid of the border: it looks like adding my clip (with larger frames) to the new project (with smaller frames) resizes (scales down) my original frames preserving borders. Probably I have done something wrong in the 3rd step of your answer, even before applying the SPR filter - should I add my clip to the new project in a special way, maybe?

Best regards and thank you again for your help!

J’ai un clip avec des bords noirs que je veux éliminer. Il apparait ainsi dans mon projet de 1280x720

I have a clip with black borders that I want to eliminate. It appears like this in my 1280x720 project

1- J’applique un filtre Crop: Rectangle pour déterminer les valeurs du recadrage.
Je note L=134, T=38, W=1014, H=646

1- I apply a Crop: Rectangle filter to determine the crop values.
I note L=134, T=38, W=1014, H=646

2- Je crée un nouveau projet en définissant son mode personnalisé sur 1014 x 646

2- I create a new project by setting its custom mode to 1014 x 646

3- J’importe mon clip dans ce projet et j’applique un filtre SPR.
Mode réglé sur “Distort”
Position L = -134, T = -38
Dimensions W = 1280, H = 720

3- I import my clip into this project and apply an SPR filter.
Mode set to “Distort”.
Position L = -134, T = -38
Dimensions W = 1280, H = 720

A l’export, j’ai bien une vidéo de 1014 x 646, sans les bandes noires et sans mise à l’échelle.

When exported, I have a 1014 x 646 video, without the black bands and without scaling.

Here is an alternative software solution that is imo easier, with basic instructions:

Thank you again so much for your immediate answers!

I still have a problem at the 3rd step. When I change the size in the SPR filter (distort mode) the clip gets scaled too (with margins). You used the word “import” maybe this is what I am doing wrong - I am just dragging my clip from my file browser to the new project - is this importing or should I do something else?

I also observed, that the pane which shows the clip contents (on your screenshots the one with the island) has in my case strange dimensions: My original clip has the size of 19201080, the desired size (which I set in Settings>Video Mode>Custom) is 985849 but after I drag&drop the clip the SPR filter shows that the frame showing panel has the size 720*577, strange. Apparently already at the moment of my dragging of the clip to Shotcut) some rescaling took place.

Apparently, I am doing something wrong. I have been using Shotcut only for two days now, hence any help has great value to me!

Thank you again and best regards

Thank you for your advice. I am only a casual video editor so I probably do not need a more advanced video editor. In fact, I seem to like Shotcut (since yesterday when I started using it :slight_smile: ) and I am amazed by the speed of getting answers on this forum. But surely I will also take a look at the program you have sent the link to.

Best regards and thank you!

Faites-vous bien cela dans le nouveau projet après avoir défini le mode vidéo?

Do you do this in the new project AFTER setting the video mode?

When an image or video is not the same resolution as the project’s Video Mode, Shotcut scales that media to the Video Mode max height or width.

I presume you mean 985x849. In the Custom Video Mode, it will round up for odd numbers entered. You may not have entered the same for “Aspect ratio” since the size you want is not the same as 16:9. So my Video Mode is 986x850 for both resolution and aspect ratio.

Since we do not have an example, I made one up from this image.

In Shotcut, just apply the Size, Position & Rotate filter. You will need to keep zooming out and reposition to find your correct settings.

Exported frame:

1 Like

Ups new users (like me) can put on this forum only one embedded media, so I will put the images clips in my next posts.

Dear Namna and Hudson555x,
thank you very much for your quick answers! Namna: I set the size after creating a new project and before importing. Hudson555x: that is exactly the problem: the movie gets scaled before I can apply any filters.

I have prepared a very short and simple example clip (the original one is too long) with size 500x400:
Let’s assume that I want to crop the black margins and leave only the green part which is 150*300:

  1. I open Shotcut and set in Settings>Video Mode the desired size (and resolution, BTW I do not understand the meaning of the second (‘ratio’), when the first (‘size’) is given, size should imply the ratio, shouldn’t it?)

  2. I drag my clip to Shotcut; unfortunately, the clip gets scaled at that very moment:

(BTW it would help a lot if this pane was displaying the frame size - using solely for this purpose crop>rectangle filter is rather strange):

I managed now with the SPR filter to obtain a video with only the important part, but:

  1. the video quality was visibly worse even in this very simple small example:
  2. surprisingly the size of the file with 150x300 movie is larger than the 500x400 clip.

I do not know how to prevent the scaling (and losing video quality) done while importing my clip. Or maybe there is another way to just crop (get rid of) the margins, without the Size, Position&Rotate (SPR) filter? Just to peel the clip from the margins?

Once more thank you for your patience in answering my questions :).

Best regards!

Just in case I attach this very small (about 300kB) 500x400 clip and the output 150x300 clip I’ve generated

Oh, it is not so easy: the forum says: "you are replying a bit too quickly, wait … " :frowning:

Second image:

Now the forum advices me: “Consider replying to several posts at once” :))

Third one

The fourth one

The fifth image

The last image:

The 500x400 clip

And finally the (slightly larger) output

What you want to do, there is no way to prevent scaling in Shotcut.

To understand Aspect Ratio, read this article: Common Aspect Ratios for Image and Video

There is with the Crop: Source filter, but it is tricky to get the numbers correct since they are in terms of the video mode resolution :frowning:

Dear all,
thank you for all your answers and hints!

I’ve tried it (also looking at old posts /comments/solutions), but always when importing/exporting to other resolutions the clip got scaled (instead of being cut/cropped).

At least I know that I shouldn’t experiment further - thank you for that information!

So I will wait for a new version of Shotcut - maybe it will have the ‘hard crop/cut off’ option :).

Guys, I love your program and I highly appreciate your willingness to answer questions on this forum (and speed of doing it). I know that I am aware of maybe 1% of the functionalities of your great software. But for such a casual video editor like me cutting and merging scenes and cropping margins (hard cropping with cutting off margins, resulting in changed resolution) is exactly what I need.

Thank you once more!
A new Shotcut fan