Crashes when opening file

I have been working on a file for a while, and everything went just fine, no crashing nothing. Then I updated to the previous version last month and all the sudden the file is impossible to open? All other files are no problem and runs smooth but this one file is impossible to re open again? I have tried to uninstall everything and install it again, but still the same problem?

I don’t know why, it just does not want to re open this project again, it tries to, and sometimes I can even see the files but then it freezes and shuts down completely. pls help!

Post a copy of the logfile and the MLT project file and someone may be able to help.

Okey, how do I do that? Sorry, im a total noob here.

Yes that is the log. Are there any error messages at the end of it?

I cannot do much with your MLT file at the moment I’m afraid. I only have my Surface Pro with me (away from home) which has only 4GB of memory and when I try to load your MLT Shotcut aborts due to lack of memory.

Hopefully someone with a production machine could hava a look at it.

Line 22 of your MLT file has the following text:

    <blank length="00:00:00.040"/>

I have never seen this in a playlist before. It may be valid, or it may be what is causing the problem.

I would make a copy of the MLT file and edit it (with a text editor) to remove this line. Then open the edited file. If it sorts the problem -great, if not - well it was worth a try.

There is more beyond just 1 line.

Yes, but I think these are just references to blank areas in the timeline, where there is no clip covering that area. I was just surprised to see “Blank” in the Playlist section, which doesn’t sound right to me.

log.txt (34.4 KB)

Here is the entire log :smiley:

There are no real error messages in the log (the ones that are there are ones that are always shown and are not relevant). Have you tried deleting the “Blank” (line 22) yet?

Hi, im so sorry, pls speak to as I am a infant. When I look at my log Line 22 is: [Info ] Mlt::Controller::resetLocale decimal point … I dont see the same as you?

The line you should try to delete is line 22 in the MLT file, not in the logfile. I’m sorry if I didn’t make that clear. Once you’ve deleted it try to open that MLT file in Shotcut and see if that works.

BUT - Please make a copy of the MLT file before you edit it, just in case.

Jep I deleted the file and messed up, now its gone.

Did you make a copy? If not, just download the version you uploaded to this thread. this is the copy:

Nemesis.mlt (621.3 KB)

You are my hero!! Thx, I will try this later tdy, need to go now, but I will get back on how it went.

Okey so I tried to remove that line but its still the same problem. It tries to open the file then breaks down.

Unfortunately I don’t have access to a system that can run your MLT in Shotcut at the present otherwise I could try to debug the problem for you.

It could possibly be a memory problem. Have you tried rebooting your system then running Shotcut without any other applications (Browser, mail-client etc.) running?

No I have not, and I have no idea how I do that haha

okey I have tried to take away the blank spots, no difference. I managed to get the file up long enough to re save it…and then I worked? The file opened up and there where no problems…for a while, then it crashed again? And now none of them will open?

are looking for the LADSPA plugin

Im sorry, what does that mean?