Crashes when I add any Image

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Anytime any form of image is added either from dragging or importing from the application it will crash. I have tried all updates on computer and application, even a full factory reset on computer to no avail. Doesn’t matter if it is a new project or not, no matter how long I am editing or using the application if at any point I try to insert an image it will crash. I have also tried running as admin, changing the format of the image, and where the image is from. I have never run into this issue until randomly today. I didn’t see anything for this but I apologize if there is already an answer. Appreciate any help!

Perhaps load the Shotcut log file here. (Just drag and drop the file)

Open Shotcut, then go to Settings.
Leave this folder open.

Load your image into Shotcut. When it crashes, leave Shotcut closed, and go to the folder you opened. Find: shotcut-log.txt

Have you tried loading images from other areas such as from your desktop? Try other drives or other data folders that you use. What image formats are you using?

Perhaps try this image: (Source)

Thank you for the reply, This is the code that it is giving me

[Debug ] LeapNetworkListener::onDisconnected Disconnected from Leap Motion
[Debug ] LeapNetworkListener::onError Leap Motion WebSocket error: “Connection refused”

The shotcut image seems to work, when i try loading it from other storage devices it works. When I try to then select a PNG file it crashes. Then even with a restart will crash again even if I use a JPG.

Those are not important at all.
I do not reproduce the problem, and I do not have an idea what the problem would be.

Sorry for the poor information. I still get it sometimes but I believe it is a hardware issue. Rather it be I don’t have enough processing power to handle it or it was because I was trying to edit off of an external hard disc. Since I have been using a M.2 I have had less issues. I appreciate everyone’s help and apologies for any inconveniences.

Hello, I also encountered the issue, I even tried version 23.04.20. With this image.

I am not able to determine what makes some images to freeze the app.

I hope posting it here will help.

After more tries, it seems it is the “%” character in the filename that makes shotcut freezes.

1 Like