Crashes when changing themes

Hi, I was pointed to Shotcut on the Manjaro Linux forum and since I edit movies from time to time I wanted to give the program a shot.
Downloaded the portable version and started it. But as soon as I go to menu preferences --> Theme and I select one of the 2 remaining choices the program crashes. I do this cause I can’t stand dark themes. Their own light theme as well as the system theme crash the program. Not a good start.
Tried to download the snapimage but all I get is a page with a unicorn saying the page took too long to load. That page opens instantly!
Then the flatpack version. I get a ref file and have no idea what to do now, but that’s me not knowing how to handle flatpacks. This is not the program’s fault.
Okay, learned how to handle flatpaks, installed Shotcut, changed the theme and crash!!!

Sorry to say this, but this is not good. Uninstalled it and in the mean time will follow the situation around this program, cause it might well be a good program for what I want to do with it.
I uninstalled it cause I can’t use dark themes, it’s something in my eyes which make me have to use extremely bright themes. It’s very hard for me to read white text on a dark background.

I use it on Manjaro Linux KDE, fully updated, using Linux kernel 4.17. Used theme is Breeze-light.

While I don’t know Linux systems, perhaps it would be helpful to provide your computer specifications so the devs can look further into this. Which version of Shotcut did you use? If it is 18.07.02 there are older versions the might want to try. You can find older versions here. A few people in here like 18.03 for stability.

I did not see a version number, it’s the one which is on the download pages right now. I guess they are the latest version available.
This is the info from my laptop:

inxi -Fxz
System:    Host: Manjaro-Hakoila-KDE Kernel: 4.17.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.1 
           Desktop: KDE Plasma 5.13.3 tk: Qt 5.11.1 Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:   Type: Laptop System: SAMSUNG product: R530/R730/R540 v: N/A serial: <filter> 
           Mobo: SAMSUNG model: R530/R730/R540 serial: <filter> BIOS: Phoenix 
           v: 08JV.M029.20100621.hkk date: 06/21/2010 
Battery:   ID-1: BAT1 charge: 24.4 Wh condition: 24.4/48.8 Wh (50%) model: SAMSUNG Electronics 
           status: Full 
CPU:       Topology: Dual Core model: Intel Pentium P6100 bits: 64 type: MCP arch: Nehalem rev: 5 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7982 
           Speed: 933 MHz min/max: 933/1999 MHz Core speeds (MHz): 1: 931 2: 935 
Graphics:  Card-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.0 driver: intel unloaded: modesetting 
           resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 18.1.4 direct render: Yes 
Audio:     Card-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.17.6-1-MANJARO 
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k v: kernel 
           bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Card-2: Marvell 88E8040 PCI-E Fast Ethernet driver: sky2 v: 1.30 port: 4000 bus ID: 06:00.0 
           IF: enp6s0 state: down mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    HDD Total Size: 585.00 GiB used: 16.08 GiB (2.7%) 
           ID-1: /dev/sda vendor: A-Data model: SP900 size: 119.24 GiB 
           ID-2: /dev/sdb vendor: Hitachi model: HTS545050B9A300 size: 465.76 GiB 
Partition: ID-1: / size: 19.56 GiB used: 11.10 GiB (56.8%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 93.25 GiB used: 4.91 GiB (5.3%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 4.00 GiB used: 512 KiB (0.0%) fs: swap dev: /dev/sda2 
           ID-4: swap-2 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb1 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 52.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 165 Uptime: 57m Memory: 3.66 GiB used: 1.59 GiB (43.5%) Init: systemd Compilers: 
           gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.12 

Memory: 3.66 GiB used: 1.59 GiB (43.5%)
Dual Core model: Intel Pentium P6100 bits: 64

According to Intel: you do have a 2GHz chip.

But with less than 2gb of memory left, it might not be enough to run Shotcut.

This is from the Frequently Asked Questions:

  • CPU: x86-64 Intel or AMD; at least one 2 GHz core for SD, 2 cores for HD, and 4 cores for 4K.

  • GPU: OpenGL 2.0 that works correctly and is compatible. On Windows, you can also use a card with good, compatible DirectX 9 or 11 drivers. We do not have a list.

  • RAM: At least 4 GB for SD, 8 GB for HD, and 16 GB for 4K.

I will try it on the desktop then, that one is much more equipped for heavy duty stuf.
I now just wanted to see what Shotcut looks like without doing real editing, but I didn’t even start yet or the program crashed. Thanks for the tip.

Someone did a whole video on what the themes look like.

I occasionally use Linux. Have Fedora 28 using the KDE plasma desktop installed in a virtual box. The latest version of shortcut (18.07.02) works well. I tried to change themes and it works fine. No crashing.

Maybe Shotcut doesn’t play well with your version of Linux. If shortcut doesn’t work for you, might want to try Kdenlive, it’s a very robust and capable video editor and has dark and light themes.

I do not reproduce this problem on Linux with v18.07 using the portable tar or AppImage. I would not be surprised if it depends on your GPU and its driver due to how Shotcut uses OpenGL through Qt 5. You can edit the config file directly to change the theme: ~/.config/Meltytech/Shotcut.conf. Look the in the [General] section for the key “theme” and change it to “light” or “system”.

Sorry, sorry, sorry, for the long wait. I’ve been very busy at work and had no time to play with the computers. Didn’t have time yet to install Shotcut on my desktop computer and also today it’s not gonna happen, have to go in a few minutes.
Thank you all for your answers, I also think the laptop (CPU and built-in GPU) are simply too small for this program. Have to use the desktop for that with an AMD FX-8350 CPU, an Nvidia GTX760 GPU and 16GB of ram. Will report back when I know some more.
Thanks again.

My desktop setup I use for Shotcut is also an FX-8350 with 16GB RAM with a 4GB Radeon R9 380 and it handles Shotcut with ease (on Windows 10 pro), so in hardware terms I think you’ll be OK.