Crash in ubuntu, missing decklink lib

Hello, the version of shotcut in ubuntu 23.04 is failing to launch with the message cannot open shared object file: No such file or directory

I’m not sure if this is an issue with the drivers or a configuration issue or what. If it’s an ubuntu issue, I’ll try to deal with them

Thank you,

The missing is not the problem; that is an optional file, and that message typically appears. You should specify what you are actually trying to install or run as there are different Linux packages.

I’m having the same problem as the OP.

Ubuntu 23.04
Shotcut version: 23.07.29
I have extracted shotcut into my /home/mksmith/bin directory
Trying to launch from the terminal

It attempts to launch but crashes with
“Aborted (core dumped)”

I get basically the same results if I try using the .appimage

If I run sudo ./shotcut it seems to launch without a problem.

Here is a clip from my log file.
[Info ] Starting Shotcut version 23.07.29
[Info ] Linux version “23.04”
[Fatal ] <> Cannot mix incompatible Qt library (6.4.2) with this library (6.4.3)

It seems I have a problem with Qt but I don’t know how to resolve it.

Some additional information.
If I delete the 23.07.29 version and downgrade to 23.06.14, the problem does not happen.

1 Like

Does this happen with the AppImage version too?

Ubuntu 23.04 includes Qt 6.4.2 so it looks like our launch script is failing to completely prioritize the bundled Qt over the system installed one. Or Qt 6.4.3 might be seeing an optional component from the system and trying to load it.

Yes, this happens with the .appimage as well.
I get the same message in the log file.
[Fatal ] <> Cannot mix incompatible Qt library (6.4.2) with this library (6.4.3)

I did a new full install of Ubuntu 23.04 (full = all supplemental software options in the installer such as apps and codecs) in a virtual machine, and Shotcut ran just fine. Next, I ran sudo apt install qtcreator to have Ubuntu install its Qt 6 packages, and Shotcut (portable) still works for me (and the incompatible error does not appear). So, something installed on your systems somehow messed things up for Qt 6, but I do not know what or how (KDE is not yet using Qt6). If you know how to use strace you might find something from the system Qt 6.4.2 loaded.

I believe I have resolved my problem.
I’m not entirely sure what fixed it.
What I did was remove qtcreator.
This in turn caused a huge number of packages to appear in the autoremove list.
So I did the autoremove.
Consequently, I wound up reinstalling flatpak and fuse which is needed for Gimp.

The new version of shotcut appears to be working now.

1 Like