'Convert to edit friendly' fails in 19.04.30


#1

Hi all,

just upgraded to Current Version: 19.04.30 and ran into that issue.
My video files are often captured with variable frame rate so Shotcut offers to ‘convert to edit friendly’ versions.

In 19.04.30 I tried all 3 options and each conversion failed.

Videos I recognized it are taken with Android app ‘AZ Screen Recorder’ (free) where I let choose the app the bit rate automatically.
UPDATE: These videos do not have an audio track! According to Pauls post below that might be the problem.

In version 19.02.28 the conversion was not an issue.

I am using the portable version.


#2

Tried with same version but on a Mac and converted to edit friendly version of Prores.
All fine here.



#3

Update to my previous post:

There is indeed something wrong with “convert to edit friendly”.
The test I did above was from fixed frame rate XDCAMHD to Prores.

I then tried a variable frame rate clip in h.264 and it failed.
I tried all three options as well and they all failed.

Another Update:

It seems that the problem lies with the audio, or rather the lack of it.
I see that SC does not pass the parameter/option “-map 0:a?” for audio.
Once I add the “?”, it converts no problem irrespective if the clip has an audio track or not.


#4

Blockquote It seems that the problem lies with the audio, or rather the lack of it.

My videos I tested do not have audio too. So that might be it.


#5

This has already been fixed for the next release v19.06