Choosing Different Audio Tracks Disables Frame By Frame Audio Scrubbing


#1

v18.10.08
Windows 10 64 Bit

There are two ways to scrub audio in Shotcut. One is by dragging the playhead and the other is by hitting the up and down arrows that are right next to the timer that tracks your current position in the timeline. I frequently scrub audio by hitting the up and down arrows since it does it frame by frame so the audio spurts heard in a frame can be very useful to me when I want to do very specific edits.

Well, if you put a video file in the timeline that has more than one audio track like in mkv files and you change the audio tracks on the Properties tab the audio scrubbing via the up and down arrows is disabled and does not come back. Dragging the playhead around will still scrub audio but doing it one frame at a time with the arrow keys does not work after that. Even if you change back to the first audio track it won’t scrub audio anymore with the arrows.


#2

Unfortunately, this is being very difficult to debug, and I must give it lower priority as a result. :unamused: