Can't open project: "This project file requires a newer version!"

Hi, this is all new for me.

I’m using: Processor Intel core i3-3240T CPU @ 2.90GHz
RAM is 6 GB
64-bit system
Windows 10
version 2004 19041.928

I have version 21.05.01 of shotcut now. (dont know how many bit or where to find this.)

I have been editing my first project(MLT) for some time without much problems ( sometimes shotcut crashes), but now when its allmost don i cant open it anymore. shotcut tells me : “This project file requires a newer version! It was made with version 21.03.21”

I try deleting en reinstalling shotcut with no result.
( it’s made with proxy and has mp4 files and jpeg files in it)

It would be awsome if someone could help me.
Thx ,
Sam

You might have it, but maybe that is not the version that is running when you open the project file. How are you opening the project file? Are you double-clicking it in Explorer or starting Shotcut and then opening it from within? Start Shotcut first, check the version in Help > About Shotcut and then open the project file.
Also, it is possible for the project file to be corrupt and report this problem. Please upload the project file.

Edit Introductie.mlt (171.3 KB)

i’m opening it from within. When i check Help > About Shotcut its ; “Shotcut version 21.05.01”

Yes, it is corrupt. From View > Application Log

[Debug ] MltXmlChecker::check end “Extra content at end of document.”

We will have to improve the misleading dialog showing in this case.

Fortunately, this corruption was very easy to fix:

Edit Introductie.mlt (171.2 KB)

thank you Dan for the quick respons and great work!
You made my day :slight_smile:

This is fixed for the next version.

1 Like