Can not resolve Size/Pos/Rotate filter transition bug

Size position and rotate filter sometimes, randomly it seems to me causes image transitions to become warped at a weird angle, see video (first image transition with SPR, but no issues, 2nd image with SPR added, but bugged):

Shotcut is up to date, recently downloaded latest version, all images are uniform aspect ratio, and I’ve tried applying various filters trying to bypass this issue but it is persistent, and the video I am currently working on is basically finished, if I can try to fix this really annoying bug.

There is no fix other than don’t do that: add that filter to a transition.

So no solution?

P.S: If I remove the SPR filter, sure it’ll remove the bug, but then the background image will appear through the transition, which is the whole point of why I add the filter in the first place

Use filter Alpha Channel: Reset, Mode = Reset, Invert.
The background shows through because the alpha channel is not opaque. The above makes the alpha completely opaque (reset alone makes it completely transparent).
This has no preset to make it more convenient, but you can save it as a Filter Set!
Another way that might avoid the problem: Crop: Rectangle with no changes.

1 Like

That Alpha Channel suggestion was a good step in the right direction - I can correct the bug on some images - however on others, for some reason or another adding that filter makes the background black. See below

Those images are not filling the frame. What is it supposed to show in that case? Outside the transition, it shows what is on V1. If you want don’t want black you are back to where you began: “the background image will appear through the transition.” Your choice: that or black… unless you resize the image to fill the frame. If you want to resize the image, add a filter to the image clip, not the transition.

It is meant to show the background image (Track V1), aka this image, where the Alpha Channel filter turns it black:

Overall, I just don’t understand why some images are bugged, but others aren’t, it’s wildly inconsistent and clearly something is wrong on Shotcut’s end

The behavior differs depending on whether images fill the frame or not. When they do not, in addition to what I already suggested, here are more suggestions:

  1. don’t use a transition
  2. use this arrangement instead

In the above, only one image is fading in opacity. In the middle of the fade, the images blend but the alpha channel remains opaque except where it did not fill the frame.
(If you also add Fade Out Video with Opacity to the image on V2 you are back to the same problem as the dissolve transition showing the V1 background–which helps explain what is happening.)

Hi @ineedhelp - off-topic, but I’m interested in music history. Can I ask what the manuscript is? Is it Albinoni? Intrigued. Many thanks.

manuscript maybe albinoni

I do not understand what you mean by “bugged”.

There are no stated image sizes or video mode settings.
I created my own.

Video mode: 1080, 60fps
V1: Background image 1920x1080
V2: File resolutions shown in file name
Each image has the Size, Position & Rotate filter setting: Fit, Center, Middle


The transition made after the filter was made to each image.
No filter was applied to the transition.

I don’t think the bug can be reproduced in such a manner, if you use enough images in the foreground with a image in the background, eventually the bug seems to occur, but there is about 30-40 images in my project that are perfectly fine before it starts to crop up.
If you don’t mind - here are 3 images, 2 of which will not transition correctly (for me at least), can the bug be reproduced on your end…? Here are some sample files,



@Hudson555x

That would be the Messa brevis (otherwise known as the Missa Gratias agimus tibi, or promissae gloriae) of Jan Dismas Zelenka (1679-1745)

Oh my God - I figured it out by pure luck and a miracle of God - Alpha Channel: Adjust > Mode: Threshold on the transition has fixed the issue entirely, and my video is complete, months of hard work paid off. Thanks all for the tips and attempts to help.

1 Like

Cool trick! Now, I am embarrassed I did not think of it :flushed: Thanks for sharing

1 Like

Hope this thread helps someone else out in the future with a similar problem - haven’t been able to fix this since I first started using Shotcut, until now =) Happy days

Thank you! Not too mainstream then! :rofl: In fact in 40 years of teaching and studying music I’d never heard of him. I’ll check him out on IMSLP.

Heavens above! He didn’t compose too much then!

As this thread is resolved I will just say, any and all score-videos on Youtube are from my channel, if you wanted to explore his works and study them also

~ ZelenkaGuru

1 Like

@ineedhelp, I found your YouTube channel! Immediately subscribed.

Oh wow, what a brilliant co-incidental find for me. 183 videos of scores and music.
Congratulations on this (groundbreaking) work.
I did wonder why we never studied Zelenka at music college! I never knew he existed even!

Not “discovered” until the late 1900s!

Another Vivaldi then - who’s works were completely forgotten about between his death in 1741 and his rediscovery in 1925.
Just listened to Zelenka’s orchestral symphony for 8 concertanti (solo) instruments:

So uplifting!
Amazing. Are all our videos made with Shotcut?
If so, even better…