Bug - empty (with spaces only) Text Simple is ignored but only when doing export

What is your operating system?
Linux

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
The bug concerns 22.06.23 and 22.04.25 (and perhaps other also but not verified) - 64 bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

Repeatable. When putting Text: Simple with empty text (containing only spaces) and colorful background, this colorful rectangle is visible on preview and on export frame. However when exporting video to mp4 it disappears (it looks like this filter is ignored).

And when mp4 video is exported it looks like this (this blue rectangle is missing).

And one photo more. Text: Simple parameters.

Never really thought of using a text filter this way. Mask: Simple Shape filter is designed for this usage.
I can duplicate the same with Verdana spaces. Not sure it’s a bug though.
Windows 10. 22.06.23

If you really want to use the Text: Simple in this manner, use the same color font and background with repeating characters.


1 Like

It’s not the question of selected font.

For me it’s obviously bug as preview during editing and export frame gives different result than export video. If all 3 cases would ignore empty Text: simple then we could discuss if it’s by design or a bug. Although even then I would assume that it’s still a bug. Moreover older version of shutcut were exporting this empty Text: simple in the way expected by me (and consistent between preview/export frame/export video).

It doesn’t change anything. When exporting video I still have empty image (this line being result of Text: simple disappears).

This is unlikely to be addressed. I suggest you learn to use other ways to draw colored boxes such as a color clip (Open Other > Color) with a filter or using the now-included Glaxnimate (Open Other > Animation).

Sorry… use repeating characters, or any text instead of spaces, along with changing the font color. I edited my original reply. Also, reduce the Outline Thickness to 0.
firefox_2022-09-02_13-26-23

First of all I’m deepely suprised that you can’t see that sth is wrong if there is difference between preview and export. So do at least the same thing in preview mode and in export frame mode then. The situation that user is suprised after export that it’s not consistent with editing mode (assuming that he or she noticed it) is never correct.

Secondly it’s just simplified example having as goal to show how the bug is created. If Text: Simple would be richer having more editing/aligning options then it would be great. Sometimes using some empty characters and mono font is the only way to align text when having many text boxes on the screen.

Concluding do whatever you want with this bug report but witch such an approach shotcut will be quite buggy software… as the situation that there is inconsistency between preview and final version might suggest that the reason of this is much deeper then just one simple filter is not working. The reason of this bug might cause that there is many more differences between preview and final export in many other filters. Not only this one. The question is by what it is caused. Not mentioning that the lack of backward compatibility is also suprising…

If you feel that strongly about it, then why don’t you do something about it beyond going on a rant to extrapolate some bullshit?

No more comments from my side. You don’t encourage people to report bugs, that’s sure!