Black background on image overlay

Also, if “Size & Position” filter is giving you troubles, try using the “Rotate and scale” filter. It does the same thing essentially and because its slightly simpler, I think the black background will go away.

Cool, thank you :slight_smile: It’s a screencast… so e.g. when I recorded the software, it wasn’t in ‘testmode’, which it should have been to demonstrate ‘testmode’. So now I just need to add the small ‘testmode’ symbol to make it look like it was there :slight_smile: But now I tried to add the small image and it blacks out the entire screen … doh
Similar stuff in other places, correcting the way the user interface was displayed. Also need to add extra information as an overlay in some places, just as a quick fade in/out…

Yeah, “rotate and scale” should be ok. Try it and tell me how it goes.

… no change with ‘rotate and scale’ - same problem.
Just had the idea to create a new track and move the clips there (though there were no visible filters or anything on the existing track, but just testing…) and strangely, the opacity is fixed, that second overlay is now working fine!! but the first one with the black background is still the same. hm…

Thanks for responding. It this point I too am confused :sweat_smile:

Thanks a lot for your help! :slight_smile:

Could be something to do with any of the main settings? Display mode? I should mention I’m not a pro and don’t no much about the techie stuff :slight_smile:

I don’t think display method would have any effect, but you can try it if you want and see what happens - remember to make backups just in case something goes wrong

Could you post in here the image you’re trying to get to be an overlay? You can just drag in the reply window.

Here I used a transparent PNG file. No filters.

Transparent PNG

sure! examples attached. and no change after testing a different display method. :slight_smile:testmode testmode

The first image next to the smiley face is a jpeg file (not transparent)
The image below “sure!” is a png (which can be transparent, but this file isn’t)
Both appear to be the same image & are of the same size.

I just applied a chroma key simple filter to the png to get rid of the gray border/background.

I think I finally figured out what you’re seeing.
Are you seeing the gray border window that surrounds your image?
If so, then that’s a box put there for you to manipulate the image.
I goes away if you click on Master, different filter, or another track.
This does not get rendered into your video.

Just click on master to see what it will render to.

Hey, thanks so much for your help! But the border isn’t a problem. The border on the actual image is part of the background that blends in. What I’m seeing is that the entire background, where there is no image, is pitch black and covers the other track. So it’s not the the space used by the filter that covers the other track, but the entire screen gets covered and with black. I don’t understand how it could be creating a black background around the filter. (See my first uploaded image at the top - you can’t see the track below, instead it’s all black around the ‘size and position’ filter)

I figured it out. Well at least I was able to duplicate the issue my way.
When you re-opened Shotcut you were probably presented with this window.
I changed this file name by just deleting the - from it. This forces Shotcut to bring up the Missing Files window.
2019-08-15_03-20-49
When you hit OK without finding a replacement, it will just be black.

After renaming the file & ignoring to find a replacement when restarting Shotcut, this is the result.
shotcut_2019-08-15_03-29-15

When reloading your file into Shotcut, double click here.
shotcut_2019-08-15_03-31-57

Replacement file selected. Click OK.
shotcut_2019-08-15_03-32-17

Now everything is back to normal.
shotcut_2019-08-15_03-33-14

Hi there! No, I was never asked to re-locate the file and the file location never changed. I have all files related to the project in one folder and all other files are working, so hopefully there shouldn’t be an issue with the file location?

Just ran a new installation of shotcut, removed the tracks with the overlay. Removed all the old images. Loaded a new image into playlist. Created a new track. Inserted image. Same problem … doh

I just found this thread in the forum:


Here they solved it by activating an option called ‘composite’ on the track - I don’t see this option. Does it still exist?

Is there any kind of setting for ‘track background’ or adding an alpha channel to a track or anything along those lines where I could be looking?

Click on the track header (in this example V2)
Click “Properties” tab. Should be set to “Over”
shotcut_2019-08-15_03-53-05

But if you set it to “None” you do get your black screen.
shotcut_2019-08-15_03-53-26

By default they are set to “Over”.

Thanks! Yeah, it’s set to ‘over’. I hadn’t changed it.

Just had another strange one: I exported a frame, cut out a section in the middle to make it transparent, created a new png and placed it on the video as an overlay. Even though the section in the center was deleted an no longer exists in the new png, it is still showing and covering the video with the entire image. There definitely is some issue with backgrounds here. But if no one else is having it, i wonder what could be causing it on my system?

Not sure how to solve the issues with your project.

You could just put your project mlt file in here and someone with higher knowledge than me can look at it.

For it to be a bug, you would have to be able to tell how to reproduce the problem.
Start from a new project, and duplicate the issue in the shortest amount of steps. Then tell us step by step how to get the same result you are getting.

So now I tested a new project with some random files - and there everything works fine!!
Somehow it must be just that one project that has the issue, looks like something went wrong there. And most likely I won’t be able to fix it… oh bummer… But at least it should work again with future projects!
Thanks a lot for your help! Really appreciate you taking the time to look into it!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.