Banner: Shotcut does not respond

I use Shotcut with Ubuntu (20.04 and then Ubuntu 22.04.2). my pc has i5-10400F processor, 32GB of memory and Nvidia 3060 graphics card.
For some time the shotcut-linux-x86_64-221221.AppImage version, which was fine before, continuously shows me the banner “Shotcut does not respond, you can choose whether to wait letting the application continue or force it to close” then the banner disappears to reappear shortly after. It seems that everything works but it interrupts the work and it’s rather annoying, I tried with the shotcut-linux-x86_64-230514.Appimage version but it gives me the same problem. does any ubuntu update cause this problem? what can I do?

Try moving the configuration file to a new location to effectively reset it and keep a backup in case it does not help.

Thank you, I use Appimage version an where I can find the configuration file? Sorry for my ignorance

ok, I have found it. I’ll try to change the position

I deleted everything inside the .local/share/Meltytech folder and inside .config/Meltytech but the problem remains.
is this an Appimage problem? No
I installed with snap “sudo snap …” but even so the issue is not solved.
What information can I give you so that you can help me solve the problem? I had already made some clips with Shotcut and I was starting to like it a lot

With AppImages you can run several versions (but yes they do share the same config folder). So what happens when you revert back to the older version. You say version 221221 used to work fine, so how about backing up and clearing the config again, and just sticking with that until the next release?

Thank you for your answer and so I have deleted the file /.config/Meltytech/Shotcut.conf. and the Shotcut folder inside .local/share/Meltytech, then I opened the last project I was working on with shotcut-linux-x86_64-221125.AppImage but after few minutes the banner has reappeared.
Before I had tried Shotcut using another pc with Ubunu 22.04 and the banner reappears.
After that I have restarted my pc with Ubuntu 20.04.06 using an USB key and Shotcut works without any banner (for the moment).
It seems clear to me at this point that Ubuntu 22.04 has introduced new features that don’t mesh well with Shotcut. I’ll report this on the Ubuntu forums and let you know if I have any news. I also hope that someone who is reading this is able to understand how to intervene. Thank you, thank you, anyway, for the support you have given me and which has allowed me to understand where the problem is

Are you using the nvidia or nouveau driver? That might make a difference. I have tested Shotcut on Ubuntu 20.04 on nvidia (with RTX 3060 card as well) with no problem, but I am intentionally not upgrading that. I have another system with Pop!_OS 22.04, which is based on Ubuntu 22.04 with AMD graphics via renoir and that too does not make that happen.

The one period I had a problem like this, it was because some big invalid value somehow got into the list of recent files in the configuration file. That causes the UI to do something slow when updating that list and the Recent panel. This is why I suggested to delete or move the configuration file. In version 23.05 I made a change to not allow storing very large values in the recent list (it is just a path string), and to move the recent data into its own recent.ini file.

So, based on that experience, it seems that your recent files list is not bad but something is making the main Qt UI thread slow and unresponsive on your system. That is why I ask about the driver. Also, in system Settings > Display are you using Fractional Scaling? This allows Scale % value that is not a multiple of 100.

1 Like

The main pc works with x server nouveau display drivers ( Sudo lshw -c display | grep driver
configurazione: depth=32 driver=nouveau latency=0 mode=1920x1080 resolution=1920,1080 visual=truecolor xres=1920 yres=1080).
I have changed these one with nvidia-driver-530-open. I have tried Shotcut with these driver (after deleting all the configuration files and now after the first tests it’s working fine WITHOUT THE BANNER!
Problem solved!!
The second pc I mentioned is a laptop (the second pc i mentioned is a laptop (sudo lshw -c display | grep driver config: depth=32 driver=i915 latency=0 resolution=1920,1080 config: driver=radeon latency=0) with Fractional Scaling at 125% which I eliminated bringing it to 100% but the issue remains (configuration files deleted and pc restarted.

This topic was automatically closed after 90 days. New replies are no longer allowed.