Audio fade in needs in = clip in (not a bug)

maybe.

an mlt I created years ago has a “audio fade in” that doesn’t seem to do much. I think it does something, but not much. for sure audio jumps from 0 to mostly loud as soon as it starts. If I remove and replace the fade in, SC setst the strart of it to “00:00:00.667”, and if I zero that out, or delete it, I get the odd not really fade,

carl@twist:~/temp$ diff template.v3.mlt template.v4.mlt
139c139
<     <filter id="audio_fade_in" in="00:00:00.667" out="00:00:01.502">
---
>     <filter id="audio_fade_in" in="00:00:00.000" out="00:00:01.502">

but this works in the t2.mlt example I created for the “filters don’t show up” report

I has this, and it works fine:
<filter id="filter0" out="00:00:00.984">

Here is my mlt that can be fixed by setting in=“00:00:00.667”

template.v4.mlt (9.2 KB)

Sorry for the half baked reports.

I think my problem is my timeline doesn’t start at 0.
I just found negative time: -0.067

<filter id="audio_fade_out" in="00:00:-0.067" out="00:00:01.902">

I have no idea why that is there. It is in a file I made with shotcut a few years ago, and have been using as a template to create production mlt files, and at some point noticed the audio fade was odd. Just now getting around to looking into it.

got it.

the in/out times are relative to the underlying file, not the timeline.

If the clip starts at 1:2:3.456, the fade has to start at 1:2:3.456.

the SC visualization takes into account duration, but it always shows it starting the start of the clip.

I hope I am using “clip” correctly.