Audio desynced after export

I just tried v18.11 and I preset 1280/720/60fps before loading my video (which was recorded at 59.94). I see the same audio out of SYNC problem.

Now, hypothetically, suppose my project had several AV sources at different frame rates (say 29.97 and 30 fps) and I was splicing these sources together. How would I select a single FPS export rate and have the audio stay in sync in v18.11?

Right, thanks Hudson555x. Yes there are myriad ways to find the recorded FPS, thanks. But until now I did not need the extra step. Shotcut tells me the recorded FPS rate when I open the file.

Where? How?

Export Tab, Advanced. Sorry I should have said “before editing my video into playlists”, not before loading it.

But I didn’t write this just for you, but for others who are reading this. It’s a choice to make when deciding what video mode is best for their project.

If you know you have a 59.94 fps video, and purposely set the video mode to 60fps, because that’s what you want, you’re just asking for problems that Shotcut is not going to sort out.


This internet is full of articles on fps conversion like this one.

I’m not sure what to tell you? I have many, many recordings that I’ve converted from 59.94 to 60FPS without any loss of audio SYNC using older versions of Shotcut as well as going from 59.94 to 30FPS using Handbrake.

So while these conversions may be challenging for the tools, they have worked for me in the past. It seems like Shotcut v18.10 and v18.11 are no longer going to support these conversions. It’s okay, I will adapt…

1 Like

If you do that before opening a video, it accomplishes nothing. Changes to Export obviously apply after a project is composed. If you want to lock your project into 60 fps, then use Settings > Video Mode. The sync problem you experience is a bug that will be difficult to fix, and I am not going to back out the change to accommodate your particular workflow. In the meantime, you can either set your Video Mode or use the older version.

Okay, so let’s call me “quirky” wanting 60FPS for no good reason. But I still think there is a larger issue here. Suppose I have 30 minutes of 59.94FPS source and 30 minutes of 60FPS source. And I am making a 60 minute video from these pieces.

What would you recommend I select for an output FPS that does not result in loss of audio sync? (Or should I go back to an older version of Shotcut to do this?)

If you are willing to change your workflow a little, choose a Settings > Video Mode with desired fps and do not alter the Export Frames/sec.

If you do not want to change your workflow a little, then use the older version.

If you are willing to change your workflow a little, choose a Settings > Video Mode with desired fps and do not alter the Export Frames/sec.

Yes! This seems to work, even for a radical change to source FPS. I just tried changing from 1080i 29.97fps to 720p 50fps by using Settings > Video Mode first in v18.11. I think that will be fine, but will try a few more experiments.

So using Settings > Video Mode works, but using Export > Advanced to set params does not. No worries, I can work with that.

1 Like