Audio Crackling?

I’m not sure how to explain this properly, so I’ve uploaded a video as a comparison.

00:00 to 00:38 is the original recording; 00:39 to 01:17 is Shotcut output.
If you listen closely between 00:46 and 00:49, you’ll notice a crackling sound.What caused this issue?

This only occurs in a few places and not throughout the video.Sometimes it doesn’t happen at all.
For this video, I’m rendering using the default settings, which are MP4-AAC.

Is it possible to still render as MP4 but with some other audio codec instead of AAC? I’ve tried MP3, but it failed to render.

1 Like

Some informatio that would be helpful:

What is your Shotcut version?
What is the frame rate of your source file? Is it variable frame rate?
What is the coded and sampling frequency of your source audio (look in the properties tab)?

For some sources, it is necessary to convert to edit friendly.

Hi, thanks for the reply.
I’m using Shotcut version 22.12.21

My source file properties:

And my recording settings:

I use Bandicam to record and had to choose AVI because I have problems with MP4 source files. The frame would freeze for a couple of seconds at each split point. The freeze doesn’t happen if I convert to edit-friendly first, but man, the converted file size is way too big. It’s like 4 times the original size, even if I don’t touch the slider.

So I just tried extracting the audio and putting it back.
First, I disabled the video by exporting it as MP3. After the job has finished, I detach and delete the original audio and replace it with the newly exported MP3. It seems to have worked since there’s no more crackling sound.

I suspect there’s something wrong with the codecs that Bandicam uses.
Do you have any suggestions for what app I should use to record videos? Maybe something that’s highly compatible with Shotcut?

As Dan already told you here it is probably variable frame rate or very long GOP. If you provide a screenshot of the properties panel in Shotcut we can see if Shotcut detects the variable frame rate. But Shotcut can not always detect it.

I know some people use OBS and they are very careful to configure the record settings to ensure that it uses constant frame rate.

You mean like this:

It seems like my MP4 recording is only 57 fps instead of 60. I record at 60fps and use the default frame rate mode which is VFR(variable frame rate)

Other setting for Mp4 recording are:
Codec: HVEC
Rate Control: VBR
Keyframe Interval: 150

I usually leave everything at default since I have no idea what these settings do.

This is almost certainly causing your problem. I suggest to change the frame rate mode to “constant” or “fixed” if that is an option.

1 Like

Yes, you are correct. It is the problem. I’ve changed the setting to CFR and now everything is working fine.
Thank you very much, Brian.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.