Audio Clicks at Split Points (even when no cuts have been made)

System info:

  • Shotcut v. 22.06.23
  • Windows 10
  • i7-10700
  • RTX 2060 Super

I’m having a problem with Shotcut introducing a click at many (but not all) of the points where I have split the track. The oddest part is that this happens even when I have not removed anything from the video or audio.

For example, I have multiple splits in the timeline in order to do some frame-by-frame masking to blur out confidential client info that was moving in the video. The only thing that was done at this point in the video was splits and adding the mask/blur filters. Nothing was removed, no audio added, no audio filters, and no other changes. But when I play it, there is a click sound at each split, which makes this part in particular sound garbled.

Timeline looks like this:

Each split on the timeline creates a “click” sound, even though nothing was removed or added to the audio. All of this is one continuous recording split only to introduce frame-by-frame video filters (masking + blur).

This isn’t the only place I have the click sound problem, but its definitely worst here since there were so many edits in a short period of time to do the masking. But, it also randomly happens anyplace I make a split.

I can resolve some of the worst of this by separating the audio and video when I am editing without actually cutting or adding, but I will still leave clicks in places where I do need to make an actual cut/edit.

The clicks are not in the original recording and are not in the converted MKV Shotcut creates when I import the recording. They are only introduced in the editing process.

I appreciate any help in resolving this.

There are some suggestions to alleviate this problem in the following post:

1 Like

A workaround solution could be filter trimming. This will set the start and end point of a filter (such as mask or blur) without requiring a split. If there is a long video clip that needs five sections blurred, then five blur filters can be added, each with its own start/end point. The underlying video clip would not need to be split at all.

Having said that, the best solution is probably to convert audio files that are not seek-friendly (such as MP3) to a format that is (such as WAV), and ensure that no sample rate conversion is happening in the pipeline. As in, all input files and export settings agree to 48k instead of mixing and matching 48000 and 44100.

1 Like

Thanks! I’ll see if changing the sampling rate and not compressing the original audio recording helps with this issue.

Thanks for the tip on filter trimming! That looks like a much better way to handle blurring than what I have been doing.
And all my input files are the same audio – it’s one continuous recording that just needs edits throughout. I do think the original video used MP3 compression, though, and I can definitely turn that off.
I appreciate the help!

This topic was automatically closed after 90 days. New replies are no longer allowed.