Audio choppy/garbled when played and encoded


#1

The latest Shotcut releases from 18.12 to date appear to have an audio issue where I can record a video using quicktime (.mov) and play the video back and the audio is fine. When I open the file in Shotcut the audio is garbled/choppy. If I encode the file to export as .mp4, the audio comes out garbled/choppy. I have to use Shotcut version 18.09.16 to get past this issue and ensure I don’t allow the app to auto update or I have the issue again.

I am on a Mac, using Mojave, all apps and OS X updates are current. I see I cannot upload the files since the file extensions are not approved. Happy to provide whatever is needed.

If I am in error in using the app due to changes in the app from the version that is working to the version that don’t work, please let me know. Happy to be at fault and things work.

My process:

  • I record my video or pieces of my video (using Quicktime screen capture)
  • I open each file in Shotcut and clip the areas I want to use and add to a playlist
  • I save the completed playlist as a project
  • Once I like how the completed project sounds, I encode it to export the file as .mp4

The process above works on older versions but the same process doesn’t work on the versions stated above.


#2

I have not reproduced this on High Sierra. I have not yet upgraded a machine to Mojave. I will retest this when I do. In the meantime, you can workaround this using Properties > menu > Convert to Edit-friendly…