Allow snapping to overrule 'unsnapping'

When snappable features (clip boundaries, playback head) are close to each other, it can be impossible to snap a clip to another clip.

The cause for this appears to be that if a clip being moved has snapped to one snappable, it takes some distance for it to ‘unsnap’. If that distance is greater than the distance to the next snap, it won’t snap to that next snap.

Demonstration video:
( I don’t know what it ended up snapping to )

Work-around exists: Zoom in until the ‘unsnap’ distance is smaller than the distance to the next snap.

You have snapping on, and you have the bottom track activated, so it’s just snapping to the bottom track.
You either have to turn snapping off, or select other track.

In this picture, snapping is turned on. It’s highlighted in blue.

It may help you to go through all of the tutorials in this link to learn how Shotcut is meant to work:

1 Like

I realize I’m still fairly new at ShotCut, and am eager to learn - preferably without frustrating you :slight_smile:

I checked out the FAQ, tutorials (including the German ones, but admittedly not the commercial course), some of the guides (english/german), and some other videos on YouTube not linked to (e.g. Teacher’s Tech), but did not see anything specific to the intricacies of snapping in the timeline beyond using it to quickly position a clip, adjoining one to another for purposes of creating a transition, and holding alt to temporarily disable snapping while dragging. If you can think of a specific one I missed, I’d be happy to view/read it.

I’m not sure if that’s how it was in a previous version, or if I have an option toggled somewhere, but that’s not the behavior that I’m seeing. While moving a clip, that clip will happily snap to clips in the same track, clips in other tracks when dragging over to that track, and clips in other tracks when staying within the same track. Selecting the other track first doesn’t affect this behavior, nor does moving the clip to that track first.

Perhaps this video will explain more clearly:

Thank you for your patience with me.

Per your video, you still have snapping enabled. Click once on the horseshoe icon to disable it.

That would defeat the entire point of trying to snap to the other clip?

Now I finally understand what you’re talking about. I guess I have not encountered this problem before. Sorry for the misunderstanding.

The best solution:

  • Move the clip from V1 to V2, but leave a space big enough to right click in
  • Right click - “Remove”. (You will not have to adjust the timeline.)


I can see how that could be very annoying though. I tried using the playhead for snapping it would not work for me in that sense either.

No worries, I figured video would communicate better what I was referring to.

While my example video was obviously engineered to bring it out, I’ve had it happen a few times editing that movie. Either in that manner, or if there was another clip near the right edge that was taking precedence.

And yes, I agree that the “right-click -> remove” is the best way to deal with it as long as there’s space to temporarily place the clip :slight_smile:

@SteeveB, using your example, I can’t snap to the next clip, even with the playhead at the spot I want it to snap to with version 18.06.02. I’ve tried with waveforms and thumbnails off, then with one on then the other.

In this picture, I can not snap the center clip in V2 to the right or left.
no snapping.mlt (8.1 KB)