Adding items to timeline pans it all the way to the left

What is your operating system?
Windows 11

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
Adding any item to the timeline causes it to pan all the way to the left, while keeping the added item in view (on the far right). Since booting Shotcut, it’s happened every single time except once, but I don’t know what I did different that time.

Gif that shows what happens:

Weird. I am not able to reproduce it. I tested on version 21.01.30 and Windows 11. And I tried different options in the timeline menu like Center the Playhead and Scroll to Playhead on Zoom to see if that makes a difference.

Well, applying the Center at Playhead option does provide an alternative remedy for the time being. It twitches to the left after dropping an item, but then re-centers.

EDIT: Scratch all that. Center at Playhead is even more annoying.

I just updated to the latest version (22.04.25) to see if that fixed it. It did not.

I have this bug.

1 Like

I have an update on the nature of this bug. It seems to not be caused by dragging items onto the timeline, but rather by simply opening an item in the source tab, then switching back to the project tab. No adding required.

I tested with 22.04.25, Windows 10.
Can’t reproduce it.
All images on SSD drives.
Did not try with HDD drives.

Perhaps provide a minimal sample project for people to test.

I think you are correct.

I’ve been able to reproduce it like this (Shotcut version 22.04.25, Windows 10):

  • New Project
  • Open Other → Colour (it also works with other clips, but just so it’s easier to test)
  • Add a decent length clip to the timeline
  • Scroll to somewhere in the middle on the timeline
  • Switch back to Source
  • Start playback on Source (in case of OP it started playback automatically when opening the file)
  • Switch back to Project (which also happens automatically when adding something to the timeline)

It will either scroll to the left or to the right, depending on whether the playback on the Source tab is before or after the time on the Project tab.

Sometimes it works several times in a row, sometimes not, not sure if there is another condition for it to happen that I missed or if it’s just inconsistent.


1 Like

I only reproduce this sometimes when the timeline option (in the timeline menu under Options) Scroll to Playhead on Zoom is turned on.

It happens for me regardless of the Scroll to Playhead on Zoom setting being on or off. It does not happen for me when Centre the Playhead is on.

Something else I noticed while testing this. I realize these are different issues and probably don’t belong in this thread, but I included them because they seem somewhat related, at least in the sense that it pertains to switching between the Source and Project tab and may provide a hint:

  • First GIF: If I switch from Project to Source and then press Space to start the playback immediately, it will stop playback again automatically (as if it overwrites the player state with some default after switching tabs, but delayed). Switching to Project isn’t as instant, so I guess it doesn’t work there.
  • Second GIF: Loading a file and then immediately switching to Project starts playback on the Project tab. Again, it seems to automatically change the state of the player (this time starting playback after loading a file), but delayed, so it affects the Project tab.

Perhaps something similar is happening with the on topic issue. The player might momentarily still be in the “Source” state (somehow due to the playback?), so it thinks it is at e.g. 5:00, the timeline jumps to that, then it updates state to the correct 10:00 of where the “Project” actually is, in which case it scrolls as expected so that the head in the timeline is on the right, the same as if you would normally scroll through the player to the right.

Of course I have no idea of how this really works in the background, so excuse my ramblings if they are nonsense.

I press Space after switching to Source:

I drop the file to set it as Source and switch to Project quickly (no other buttons pressed):