A/V synch problem


got a video of me playing the guitar from my phone that I put in Shotcut.
I created an audio track and inserted my guitar audio file recorded with Live.
In the shotcut viewer I synched perfectly audio and video.

I exported the MP4 video and the video was late for a few ms compared to the audio.
For 3 hours I tried every solution I could think of to get a synched exported video but none worked.

Finaly, what I did is push back my audio track on the right for 2 frames, so 8ms for my 25fps video, and that did the trick.

Now I am very glad I found this solution, but I’d like to understand why there is this 8ms delay when exporting the video, and there is no delay when viewing the video and audio within shotcut before exporting.

Any idea?

What kind of phone are you using?

What is your Shotcut version (see Help > About Shotcut)?

How long have you been using Shotcut?

Have you before on Shotcut done similar kinds of projects with footage from your phone and added separately recorded audio? If so did the same thing occur before?

I’m using a good Samsung and using the very last Shotcut version.
I use Shotcut for months now, and always had the same problem when using GoPro 8 videos.
I just decided to post about it today because it’s really annoying me ha ha.

What Samsung model is it?

Please give the actual Shotcut version number you have.

Also, select your video that is on the timeline then go to the Properties tab. What is the exact frame rate that is listed in the Properties tab for your video? And does it say “variable” in parenthesis next to it?

My phone is a A50.
Shotcut version is 21.05.18.
The video I’m using in the timeline is 30.000000 fps and was previously converted by Shotcut as it was variable.

Thanks for your help.

So here is how I fix the problem:

  • I perfectly synch the audio track with the audio contained in the video (peak to peak using max zoom)
  • I trim the beginning of the audio and video tracks at the same position
  • I set the Current position to frame 6
  • I align the beginning of my audio track to frame 6
  • I export the video which renders perfectly synched!

So my video being 30fps, each frame is 33.333 ms, so I have to push my audio to the right for exactly 200ms to get perfectly synched.

This is weird, as the sound from my original video is perfectly synched.
Looks like Shotcuts is adjusting the video audio part and makes it appearing 200ms (6 frames) earlier than it should…

Your thoughts are welcome!

It can also mean there is delay with your computer’s audio/video setup. This can sometimes be caused by external sound cards especially. The audio libraries used during editing are different than what’s used by media players for playback.

Now that you know the offset is 200ms, you could go to Settings menu > Synchronization and put in 200ms so that the preview player will match the export sync. Then you can edit like normal without having to think about offsets. When it sounds good, it will be good.

I tried this Synchronization setting, it does not change a thing. Even tried the maximum, + and - 250ms, it did not change anything in the synchronization…

And as I said, I synchronize audio track with the audio included in the video using the audio graphics with max zoom, so it should be ultra precise.

Synchronization changes preview sync, not export sync.

There’s also the possibility that the cell phone is writing delayed audio to its MP4 file. Or since it was converted from VFR, this offset was the closest that conversion could get to mapping a constant frame rate.

What format is this file? If it’s MP3 or WMA, then that’s likely the problem. Try using a different format like WAV or AC-3 that doesn’t have codec delay.

Austin, converted video has it’s audio perfectly synch, so this is not the problem.
For my audio track I use WAV file, so this is not the problem either.

Ok folks, I have found the problem, and I think it is a Shotcut bug: when loading the video file, converted to fixed rate or not, Shotcut introduces a 200ms (6 frames) delay between the included audio and the video. As a proof, when I read the video in an external viewer, audio and video are perfectly synched, as when read in the Shotcut timeline or in the Shotcut exported video, video is late by 200ms compared to audio…
I get the same proplem when using my Samsung A50 videos or my GoPro 8 videos, 30 or 60 fps.

1 Like

Yes, I have the same problem, with both my laptop computers. multiple video sources. maybe not exactly the same delay, but yeah, it’s annoying. I just updated from v20 to the latest v21 and the bug is still there. I thought this bug would have been fixed by now.

This topic was automatically closed after 90 days. New replies are no longer allowed.