250ms Audio Lag

When opening up an MP4 file, there is about a 250ms audio lag in Shotcut.
Original MP4 audio is in sync with windows media player before editing.
Beyond setting every single file properties to +250ms Sync is there an easier way?
When going to export, the lag is in the final production.
The MP4 files are on HDD. Would a SSD make any difference.
File sizes are about 1gb to 2gb, most being 1.2gb in total size (1 hour in length).
Lag is present in MP4’s using 1, 2 or 3 audio tracks.
Using Shotcut version 17.12.03

I figure I must have a setting off somewhere in the software.
Any suggestions would be appreciated. I really love this software.
Thank you.

Audio Codec AAC, 48KHz
Recording Software: OBS 20.1.3 (64 bit)
Editing games that I play on Steam.

Computer Specifications:
i7-7700K Kaby Lake Quad Core 4.2 GHz
ASUS ROG Maximus IX Hero Z270
G.Skill Ripjaws V 32GB
Deepcool Gamer Storm Captain 240EX CPU Liquid Cooler AIO
EVGA SuperNOVA 750W Platinum
Keyboard: Aukey KM-G3
Headset: Sennheiser PC 350 Special Edition 2015

GeForce Experience is installed, but turned off (msconfig at start menu)

HDD or SSD won’t matter. Have tried playing the MP4 back on VLC, etc, to see if the offset shows up there?

What’s the source of your MP4’s?

My initial thought is the problem isn’t in Shotcut but in the files. I’ve brought in dozens of MP4’s while doing a series of videos headed to YouTube. None of them show this delay. I do lose 1-2 frames of audio at the end of some files, but that’s a known problem in the camera’s firmware.

The original MP4 audio sync is fine.
The lag occurs when I open it in Shotcut.
I don’t know what VLC is.


VLC plays video as well as audio, and can be adjusted to put video and audio in sync.

Take a look at MPC-HC - it’s a good viewer and, I’ve found, less temperamental than VLC can be.