18.09.13 Text with Rotate and Scale filter bug


#1

Found a bug with the text and rotate and scale filter.

Create a transparent clip and apply a text filter to it. Put just one character in the text field then apply a rotate and scale filter. The text character is distorted. If you place a space before or after the character and you apply the rotate and scale filter there is no effect on the text.
This happens with color clips images and video clips.

Texr bug.mlt (9.9 KB)


#2

I had a similar issue but with using a picture instead.


#3

Sorry Dan, I also have to report some buggy behaviour with 18.09.13.

I tested a Text clip on transparent background on V1.

Bug #1: Apply Fade in or fade out - Doesn’t work.

Bug #2:
1.Apply Rotate/Scale filter when playhead is in the middle of the clip (ie not at very beginning)
2. Red node appears as expected.
3. Attempt to go to beginning of clip (seek previous keyframe) - doesn’t work, playhead doesn’t move.

Bugs #3, #4: Same as bug #2 but also happening with Opacity and size/position filters. Maybe other filters too? (not yet tested).

I’m going to have to go back to 18.08.14 until this is resolved.

On the positive side, I love the new snapping feel and of course the open>other>text feature is cool - thank you for that!

[EDIT - oops, just tried Bugs#2,#3,#4 with 18.08.14 and it doesn’t work as I expected either!! Is this intended?] Apologies if so.


#4

I reproduced this. It is a regression in the engine’s filter that is used by Text, Timer, Size and Position, and Rotate and Scale filters.

Works for me.

If you are at the leftmost keyframe then there is no previous keyframe to seek to. Use another seek button such as the one on the first row of the Keyframes panel or on the player.


#5

I just fixed this bug. It was a code copy and paste error that went undetected. I think it warrants releasing a new version.


Just trouble trying just to rotate video
#6

So far everything else has been working well. I like the new ripple support.:+1:


#7

Ah, OK, thanks, will have another test when I get a chance tomorrow. [EDIT: Just tried very briefly, it worked OK. Ignore me !] :roll_eyes::roll_eyes:

Thanks, will try that.