16.11.02 crashes after undo(s)

Under SUSE Linux 14.1 and 16.11.02:
While working on a project, I tried to back out some transitions. After 2-3 Undo’s (menu or CTL-Z) Shotcut simply vanishes. Otherwise things are stable.

Reproduced on Windows 10, Shotcut version 16.11.02. But instead of Shotcut vanishing I get a crash.

However there are some more specific conditions that this only happens on.

  1. The cut and dissolve transitions don’t produce this (so it has to be something other than those two)
  2. You have to be undoing while the timeline plays (if you pause and then undo it won’t crash)
  3. The header must pass through at least one of the transitions in order to produce this

I hope this extra information is useful or similar to what you’ve experienced.

I’ll check all of those out under Linux and Win 10. At the time I found this, I was in the middle of a project and didn’t have time to troubleshoot. It’s done, now I have some time to play.

FWIW, I’ve never seen an obvious crash indication when this happens. Shotcut 16.11.02’s window just vanishes. IIRC, it’s after two undo’s; attempting the third undo is when Shotcut fails.

Alright, thank you. :slight_smile:
And yes I noticed it was crashing for me at the third undo as well

Edit: I only just realized that what you meant by “vanishing” is basically the same as a crash for me :rolling_eyes: that’s my mistake, sorry.

Later I will create a full list of steps. Thank you for your help!

Win 10:
I tried this with five filters (rotate, lens correction, rotation to adjust scale, white balance, and contrast). I did a dissolve, but the play head went back to home, L to start playback, and three CTL-Z’s after the play head went over the transition. No problem found.

The same sequence failed - Shotcut “went away” with no “process failed”, etc. message.

Go figure…

Tested on OSX as well actually, also reproduced a crash.

Here is a list of the simplest steps I used in order to reproduce.
Note that it only works with transitions, not filters, and the transitions cut and dissolve are exceptions.

  1. Load a clip into the timeline.
  2. Split the clip into two and overlap both to create a transition.
  3. Select the transition and change the transition type to something other than cut or dissolve.
  4. Begin playback so that the playhead passes through the transition.
  5. Perform an undo action 3 times, either via the menu or using ctrl-z.
  6. You should get some sort of terminating result, which may vary based on operating system but they all basically crash the program.

I’m not sure if you were struggling to reproduce it on Windows or you were just testing for other crashes, but I hope this helps.

Sorry - I thought I’d responded to your post. Anything I try the stress test on crashes.

Cheer up - at least it’s a reproducable problem.

Still happens on the newest version, 16.12.03, so I made a github report about the issue. Sorry for any delay.

Edit: link

This issue was fixed for the next release 17.01.